configure IPv6 using DHCPv6 on TP-Link TD-W9970 router

Started by krysia, Sep 13, 2020, 11:26:28

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I posted this yesterday in the 'Help' section, but it might fit better here.  Anyone know how to configure IPv6 using DHCPv6 on a TP-Link TD-W9970 router?  We're upgrading from ADSL2+ to FTTC on Tuesday, and I'm not sure the steps I'm planning to take are sufficient.  Here's what I think is the relevant page under 'Network' (sorry - screenshot won't paste):

IPv6 LAN Settings The parameters of IPv6 LAN can be configured on this page.
Note: Only the default group will support IPv6 at this moment.
Address Auto-Configuration Type: RADVD or DHCPv6 Server
Enable RDNSS:
Enable ULA Prefix:
Site Prefix Configuration Type: Delegated or Static
Prefix Delegated WAN Connection:

IDNet has told me to check the box for DHCPv6 Server, to enable RDNSS, and to keep the configuration type as Delegated, but I don't know where to put the Route, Prefix, and DNS Server information that IDNet has sent me - they are the same as our current DNS IPv4 and DNSD IPv6 settings on ADSL2+, but I'm not sure whether they'll still be there once I configure the router with the new VDSL settings (though we're already on PPPoE rather than PPPoA). Are there any other router pages I should change?  Thanks for any advice you can give me!


Sorry you didn't get an answer yesterday.  If anyone was around who could have answered it, I'm sure they would have.  It's certainly beyond my depth of understanding of this stuff.  I'd suggest Nowster might be the one for this so hopefully he will see it soon.  :)
This post reflects my own views, opinions and experience, not those of IDNet.


Which interface are you trying to do DHCPv6 on? Internal LAN or the external FTTC one?

If you're already using PPPoE settings on ADSL, you probably won't need to change anything for them to also work on VDSL.


Many thanks for your reassuring reply about our already using PPPoE for ADSL.  I don't really know the answer to your question about the interface we're using for DHCP6, but yesterday, after posting this, I had a reply back from the TP-Link support centre, much faster than I thought it would come.  They sent clear instructions about setting up IPv6 via the router's Wan service set-up, so I think it will go okay tomorrow.


This is what I did with the VR900 - and it worked:
- under Advanced/Network/WAN Interface, choose to modify the only interface listed (pppoe_ptm_101_0_d)
- under Internet Connection Setup, Enable IPv6 and choose DHCPv6 as Addressing Type. (The IPv6 Gateway should be the same as the WAN Interface listed above.)
- choose LAN Settings and select IPv6 under DHCP Server, then it's just a matter of selecting RADVD (not DHCPv6 Server) as Address Type and Delegated (not Static) as Site Prefix Type. (Again, Prefix Delegated WAN Connection should show the same WAN Interface listed above.)
The Starting and Ending Address lines you quote should only appear if you're selecting DHCPv6 Server as Address Type - which you don't want. You want RADVD.


Thanks for those beautifully clear instructions, faircot.  TP-Link's instructions didn't work, so following IDNet's advice, I deleted the IPv6 setting.  I've just gone into the router again to follow your instructions, and they worked (see IPv6 Wan info below).  I'm not sure it's okay, though, because the status is 'connecting' rather than 'connected'

Name                  Connection Type   VPI/VCI or VID   IPv6 Address/Prefix Length   Gateway                  DNSv6   
pppoe_ptm_101_0_d   PPPoEv6   101                      :: /0                      fe80::02a3:8eff:feca:ae80   2a02:390:1::64:6e73 and 2a02:390:2::64:6e73   

After posting this, I ran an IPv6 test and everything appears okay, with a score of 17/20.  The site said there are a couple of problems: 
'Your router or firewall is filtering ICMPv6 messages sent to your computer. An IPv6 host that cannot receive ICMP messages may encounter problems like some web pages loading partially or not at all.'
Also, it said there's no reverse DNS record.

Do I need to do anything about any of that?

Many thanks again for enabling me to configure the router correctly after many frustrating goes and giving up!