Recent Posts

Pages: [1] 2 3 ... 10
1
You could pick the bones of this thread and you might get lucky:

https://superuser.com/questions/543067/why-is-my-usb-flash-drive-now-read-only

If it's affecting more than one drive, have you tried using a different USB port?
2
Thanks for the heads-up, Mitch.  Unstickyfied.
3
Just adding a note that Towerup doesn't seem to be in operation anymore, while I understand the moderation team might want to keep the thread for historical purposes as it does contain some excellent witty comment from the late, great Rik the domain could be acquired by someone else in time and linked to content not related.
4
No, just a thicko!  :red:
5
Are you sure you've not got a poltergeist in your house that keeps causing these mysterious problems?   :facepalm:
6
Why? I cannot correct that by the usual means of selecting attributes then changing them. so 2 questions, why has it suddenly done that and second how do I correct it. By the way it is Windows 10
7
It has, all on its lonesome, started working!  :o
8
Disk manager shows it as a healthy (primary) partition. I have copied the backup from the other drivre to this one, it copied fine, however, not surprisingly it will not rim with EaseUs. I tried another backup with the same failure.
9
Has the drive been partitioned?

What does it show in Disk Manager?
10
From the backup utility. there are no errors that I can see anywhere.
Pages: [1] 2 3 ... 10

Any information and links published in the forum are posted in good faith, but the forum staff and
owners cannot and do not accept responsibility for the content and accuracy of external websites.